BetterPhoto Q&A
Category: New Questions

Photography Question 
Tammy L. Newcomb
BetterPhoto Member Since: 4/23/2006
 

Adobe Photoshop


I feel as if I am at a real disadvantage because I have an outdated version of Windows. I am still operating on Windows 98 2nd edition. All free demos that the Adobe website has to offer is supported with XP, nothing I seen for Windows 98.

My questions is: Do any of you have an older version of Photoshop that would work with Windows 98 that you may want to pass along.

Thanks,
Tammy


To love this question, log in above
7/24/2006 5:00:20 AM

 
John P. Sandstedt
BetterPhoto Member Since: 8/8/2001
Contact John
John's Gallery
  Photoshop Elements 1.0 and 2.0, Photoshop 5.0 and, maybe even 6.0 will work with Windows 98 SE.

ELements 3.0 and 4.0 will not. Photshop Cs and CS 2.0 will not.


To love this comment, log in above
7/24/2006 7:06:06 AM

 
Slim Brady 
BetterPhoto Member Since: 3/1/2006
  you don't need PS, your photos are great


To love this comment, log in above
7/24/2006 10:49:54 AM

 
Log in to respond or ask your own question.