BetterPhoto Q&A
Category: New Questions

Photography Question 
David Nadeau
 

Canon 1Ds with Studio Strobe (Not Firing)


Hi all,
Just got a used Canon 1Ds (non-Mark II) and I'm having problems with getting the flash to fire. I have a Speedotron 805 studio pack. The camera is connected to the pack via pc cord plugged into a Wein HSHSB adapter in the hot shoe. I've tried shooting in all modes including Manual.
Am I missing something? I even tried reading the manual to no avail.
Any suggestions would be much appreciated.
DN...


To love this question, log in above
8/29/2005 8:05:17 AM

 
Jon Close
BetterPhoto Member Since: 5/18/2000
  Could be a loose connection between the PC cord and Safe-Sync, or the Safe-Sync isn't fully in the shoe of the 1Ds. You might also try connecting directly to the PC socket of the 1Ds (the manual says it is safe terminal voltage up to 250v).

Also check the polarity of the connection to Speedotrons. The 1Ds manual (p. 114) states "There are studio flash units whose sync cord polarity is opposite from the camera's PC terminal. Such flash units do not work with the EOS 1Ds camera unless the polarity of the sync cable is changed. Consult the manufacterer of the flash unit or purchase a commercially-available polarity conversion cord."


To love this comment, log in above
8/29/2005 11:02:17 AM

 
David Nadeau   Thanks for the response, Jon.

Checked all connections and tried regular pc connection with no luck. Tried putting the safe-sync on my old G3 and it fired no problem.

As far as the polarity conversion cord goes, the guys at B&H Photo couldn't locate any such item. They also had no other suggestions aside from going wireless.
I guess I'm screwed. I'll see if I can pick up a cheap slave set-up.

Cheers,
DN...


To love this comment, log in above
8/29/2005 12:37:08 PM

 
Log in to respond or ask your own question.