steam engine

© Timothy L. Leggett

steam engine

Uploaded: October 02, 2003

Description

white balanse set to outdoor, ISO set to 400 car speed set to 55 MPH (LOL) I spotted this locomotive as we were driving passed a railroad museum in flagstaff unfortunately didn't have time to stop so I aimed out the window and shot.

Comments

Lori Ditlefsen October 02, 2003

You did a good job for 55mph LOL. Nice shot! #63581

Timothy L. Leggett October 03, 2003

Thanks Lori I'm a little behind but I'll start looking at everybody's shots that I have missed soon.

Tim #219664


To discuss, first log in or sign up (buttons are at top center of page).

Get Constructive Critiques

Sign up for an interactive online photography course to get critiques on your photos.


 

Did You Know?

BetterPhoto Websites: If you see an orange website link directly under the photographer's name, it's totally okay. It's not spam. The reason: BetterPhoto is the one that offers these personal photography websites. We are supporting our clients with those links.

Unavailable EXIF: If there is no other information but 'Unavailable' in the EXIF (meaning no EXIF data exists with the photo), the 'Unavailable' blurb is not displayed. If there is any info, it shows. Many photos have the EXIF stripped out when people modify the image and resave it, before uploading.


 

The following truth is one of the core philosophies of BetterPhoto:

I hear, I forget.
I see, I remember.
I do, I understand.

You learn by doing. Take your next online photography class.


Copyright for this gallery photo belongs solely to Timothy L. Leggett.
Images may not be copied, downloaded, or used in any way without the expressed, written permission of the photographer.
Log in to follow or message this photographer or report this photo.